Back to overview
Downtime

VPS Outage | All Services Offline

Apr 27 at 11:23pm EDT
Affected services
rickyjs.xyz
Proxy
BDFDData
RickyJS Database
BDFDData Database

Resolved
Apr 28 at 02:23am EDT

After an unplanned maintenance, our provider has fixed the issue

Created
Apr 27 at 11:23pm EDT

We are currently experiencing issues with our VPS. We are working with our provider to resolve these issues.