VPS Provider Issues
Resolved
Sep 16 at 10:30pm EDT
Issues have been resolved. Thanks for your patience during this outage.
Affected services
rickyjs.xyz
RickyJS Database
Proxy
BDFDData
BDFDData Database
Updated
Sep 09 at 01:30pm EDT
VPS Provider is looking into the issue(s)
- Contabo, our VPS provider, is now looking into what happened. I believe (and hope) they are working diligently to resolve this.
Recap
A major version upgrade of Ubuntu was preformed, and something went wrong (clearly). There is a lot in there air on what is to happen.
All services excluding the Proxy are experiencing downtime.
BDFDData API has degraded performance
For the time being, until new information is available. The following modifications have been implemented.
Database is unreachable
- Disabled the obligatory use of Api Keys. Api is free public use
- All DB endpoints are disabled
I would like to remind you that there is no ETA on the fixes. Just hoping for the best.
Affected services
rickyjs.xyz
RickyJS Database
Proxy
BDFDData
BDFDData Database
Updated
Sep 09 at 01:00pm EDT
- Proxy recovered.
- BDFDData degraded.
Affected services
Proxy
BDFDData
Created
Sep 08 at 02:00am EDT
Their was a major update to the VPS operating system (Ubuntu) and the database didn't like it at all! The moment it updated, the database was corrupted and resulted in a major collapse in everything else. Since everything depends on the database, everything is affected in major ways.
We have no ETA on when this will be fixed but we're actively working on it. Please understand that we're probably more upset than you are so don't bring snark about it. If you have any questions, feel free to ask but we can only tell you as much as we know ourselves
Affected services
rickyjs.xyz
RickyJS Database
Proxy
BDFDData
BDFDData Database